Login | Register
SearchMy Stuff
My ProfileMy PreferencesMy Mates RSS Feed
Reply to Topic
Author Discussion

V88Dicky

Original Poster:

4,961 posts

63 months

[news] 
Monday 9th July 2012 quote quote all
So there I was, accelerating out if a 30 into an NSL in third gear, about two-thirds throttle, when the check engine symbol flashed up. By pure chance, I glanced over to the oil pressure gauge and to my horror the needle was on the bottom. yikes
Pulled over pretty damn quickly and switched off, and took a few moments to gather my thoughts.

No oil under the car, no untoward smells, dipstick level ok, everything checked out fine, water temp ok.

I'm hoping it's just a sender, what do you think folks? frown


Passed it's MOT today too biggrin

snowwolf

9,925 posts

55 months

[news] 
Monday 9th July 2012 quote quote all
It probably is just the sender, but I would not drive it until you know for sure there is pressure there.

V88Dicky

Original Poster:

4,961 posts

63 months

[news] 
Tuesday 10th July 2012 quote quote all
Cheers Snowy, I'll get it checked out today, and it's at AAS for servicing and some goodies tomorrow. thumbup

Tempy

1,741 posts

75 months

[news] 
Tuesday 10th July 2012 quote quote all
Sounds like the same thing that happened to mine. Nice easy and cheap fix hopefully. Mine was.

Here's some info. Good luck biggrin

http://www.pistonheads.com/gassing/topic.asp?h=0&a...

V88Dicky

Original Poster:

4,961 posts

63 months

[news] 
Tuesday 10th July 2012 quote quote all
Thanks mate. I'm confident that's what it is, but there's always the nagging doubt in my mind! Been out to check her over again, just to be sure. Dipstick level good, no leaks anywhere, runs fine but only reads 1bar. Let's hope its just the switch smile
Advertisement

monkfish1

5,417 posts

104 months

[news] 
Tuesday 10th July 2012 quote quote all
V88Dicky said:
Thanks mate. I'm confident that's what it is, but there's always the nagging doubt in my mind! Been out to check her over again, just to be sure. Dipstick level good, no leaks anywhere, runs fine but only reads 1bar. Let's hope its just the switch


If its reading one bar its unlikely to be the switch. Ive only seen switches read zero or max. Stop driving until you know the real oil pressure. There is a handy test port on the sump, at the rear right hand side. unscrew the bung and plug in a real mechanical gauge.

V88Dicky

Original Poster:

4,961 posts

63 months

[news] 
Tuesday 10th July 2012 quote quote all
Thanks Roger. To be on the safe side, I'm getting it recovered to AAS in the morning. Hope it's not the oil pump! rolleyes

ETA: the oil pressure light hasn't came on at all, I'm kind of hoping that's a good sign?

Edited by V88Dicky on Tuesday 10th July 15:48


Edited by V88Dicky on Tuesday 10th July 15:48

monkfish1

5,417 posts

104 months

[news] 
Tuesday 10th July 2012 quote quote all
V88Dicky said:
Thanks Roger. To be on the safe side, I'm getting it recovered to AAS in the morning. Hope it's not the oil pump! rolleyes

ETA: the oil pressure light hasn't came on at all, I'm kind of hoping that's a good sign?

Edited by V88Dicky on Tuesday 10th July 15:48


Edited by V88Dicky on Tuesday 10th July 15:48


Oil light wont come on until it drops below 10psi. 1 bar is 14 ish.

V88Dicky

Original Poster:

4,961 posts

63 months

[news] 
Tuesday 10th July 2012 quote quote all
Fair enough. Cheers Roger. smile

V88Dicky

Original Poster:

4,961 posts

63 months

[news] 
Wednesday 11th July 2012 quote quote all
Phew!!! Just the pressure sender. After having the car recovered to AAS, and carrying out a pressure test, turns out it was just the oil sender. Better safe than sorry I guess.

Best news I've had after a crappy week thumbup
Reply to Topic