Login | Register
SearchMy Stuff
My ProfileMy PreferencesMy Mates RSS Feed
Reply to Topic
Author Discussion

JeffC

Original Poster:

1,014 posts

96 months

[news] 
Friday 13th March 2009 quote quote all
my 330d E90 M sport has developed a problem, it started a month ago with the music switching from cd to radio, Its done this a fair few times but I never worried, anyway jumped in it this morning no music and all ive got is the bmw logo in the screen , the menu button isnt working and every now and then the screen will go blank then back to Bmw?? worst bit is Ive got no tunes as everything works through the i drive !

can anyone shed any light on this ?

bt the car was three years old last December so now out of warrenty frown

Junior Mint

141 posts

123 months

[news] 
Saturday 14th March 2009 quote quote all
Have you tried to reset the iDrive? Hold both eject buttons and them push the radio knob. This will carry out a CCC reset and may cure your problem.

If this doesn't work try a battery reset. Just disconnect the earth terminal for about 30 mins at least.

My iDrive is so flaky, it really is a pain.

JeffC

Original Poster:

1,014 posts

96 months

[news] 
Sunday 15th March 2009 quote quote all
wierd one it came back on the same day and has been fine since confused I did disconect the batter for an hour but that didnt make any difference.. Ive got it booked into the main stealer but not sure if i should cancel it or see what they say, guessing they will update the software but this will remove the remap and reset to standard frown

John the Blind

87 posts

100 months

[news] 
Thursday 19th March 2009 quote quote all
Had the same on my 56 plate. CD to radio, Different radio stations that I never listen to etc. Intermittent and I assumed that the dealer would say nothing wrong.

I reported it and there turned out to be a PUMA update available. Worth doing as there were a number of small but good improvements.

Little things like a better search facility for information and the traffic reports appearing with the closest incident first. Different graphics also.

Only problem is that you lose all of your presets and IMO the voice recognition does not appear to be quite as good (but that might just be me).

I would mention it next time your in, and they will be able to tell you what version your on.

John

Edited by John the Blind on Thursday 19th March 20:37

havenswift

2 posts

55 months

[news] 
Sunday 3rd January 2010 quote quote all
Hi

I have a 2004 530i that has just developed exactly the same problem. iDrive only shows either a blank screen or the BMW screen and nothing works including the radio. Does anyone have any ideas please ?

Thanks
Ian

Do you have a website and need a competitive quote for hosting ?
Please visit Havenswift Hosting

Edited by havenswift on Sunday 3rd January 16:55

Advertisement

JeffC

Original Poster:

1,014 posts

96 months

[news] 
Sunday 3rd January 2010 quote quote all
well as an update, mine reset the first time and was fine till around November? reset it again but only lasted a week then went off for a week, booked it into main stealer last month and the day before it came back on! anyway sent it in and they uploaded new software on the ecu, all functions now are much better/quicker , display is totally different only down side is its set the ecu back to standard and car feels as flat as a witches tit !

havenswift

2 posts

55 months

[news] 
Sunday 3rd January 2010 quote quote all
I have tried the reset mentioned above but it doesnt seem to do anything - is this standard for all iDrive systems ? If so, what am I doing wrong ? I might try disconnecting the battery tomorrow if there is no other solution.

Thanks
Ian

Do you have a website and need a competitive quote for hosting ? Or want someone to design a website for you ?
Please visit Havenswift Hosting
Reply to Topic