Login | Register
SearchMy Stuff
My ProfileMy PreferencesMy Mates RSS Feed
Reply to Topic
Author Discussion

rumpelstiltskin

Original Poster:

2,684 posts

143 months

[news] 
Tuesday 27th October 2009 quote quote all
Hi,just bought a 2.5 V6 Rover 75,previous owner says the airbag light come on the dash after he had hoovered the carpet and it hasn't went off since.I've been told to try and push the blue and yellow connectors under the seats to make sure they are fully home.Done this,also pulled them apart and cleaned them,light is still on the dash?,anyone know anything else to try?

selwonk

1,706 posts

109 months

[news] 
Tuesday 27th October 2009 quote quote all
I used to squirt a bit of WD-40 onto the contacts before reconnecting. Used to do the trick...

rumpelstiltskin

Original Poster:

2,684 posts

143 months

[news] 
Tuesday 27th October 2009 quote quote all
I've tried that,light still staying on!I know the lights not the end of the world but someone told me while it's on it immobilises the airbags etc?

selwonk

1,706 posts

109 months

[news] 
Tuesday 27th October 2009 quote quote all
How tight is the cable? Do you have the seat on it's furthest setting backwards?

rumpelstiltskin

Original Poster:

2,684 posts

143 months

[news] 
Tuesday 27th October 2009 quote quote all
I doubt the guy who i bought the car of would have it that far back,he was quite small.Is it ok to take all the rest of the connectors apart under the seat and spray them with WD40 as long as the ignitions off,someone told me to wait 5 minutes to disconnect things after car is off?.The only connectors i have cleaned so far are the blue and yellow connectors under the drivers eat,and the same colour connectors under the passenger one.I'll check to see if anything looks like it would be pulled with the actions of the seat.
Advertisement

Petemate

1,549 posts

75 months

[news] 
Wednesday 4th November 2009 quote quote all
Had this with my Rover 45 TDI soon after I bought it. Traced the problem to the connectors under the seats; first it was the driver's one then a week or so later the passenger's one. After curing nearly two years ago no further problem. Cure was disconnecting - liberal spraying with Maplin switch cleaner - reconnecting.
HTH
Pete

rumpelstiltskin

Original Poster:

2,684 posts

143 months

[news] 
Sunday 8th November 2009 quote quote all
Been told to cut out the connectors and solder the wires together which i've done.Airbag light is still on in dash?

kiwi paul

1 posts

31 months

[news] 
Saturday 14th January 2012 quote quote all
Re Airbag light staying on Rover 75 dash, after reading reviews on your site, i checked the connections under the passenger & drivers seat, (yellow & blue) and after a bit of a wiggle the warning light came on with the ignition & went off after 4 secs, as it:s supposed to do. Had no trouble since. The ignition was turned off whilst checking the wiring!! Thanks for your reviews, saved me a few bob, Cheers.

restoman

618 posts

92 months

[news] 
Thursday 16th February 2012 quote quote all
rumpelstiltskin said:
I've tried that,light still staying on!I know the lights not the end of the world but someone told me while it's on it immobilises the airbags etc?
Glowing airbag light is now an MOT failure . . . .

Reply to Topic