Legacy

Author
Discussion

spunky-mon

Original Poster:

897 posts

159 months

Monday 16th January 2012
quotequote all
Hey folks, boy at my work is having a problem with his car. When starting from cold it rattles (sounds like the heat shield, but this was fixed and the noise is still there) Only happens when it is moving and goes away when the car is warmed up.

Any quick ideas before putting it to a garage?

ScoobieWRX

4,863 posts

176 months

Monday 16th January 2012
quotequote all
A rattle that goes away when warm.....if he can't find it when the vehicle is cold then best get it to the garage as it could be anything from an exhaust heat shield to a noisy bottom end.

Failing that it could be the spare change in the center console scratchchin

NorthDownsScooby

170 posts

119 months

Monday 16th January 2012
quotequote all
Piston slap...?

Watchman

5,775 posts

195 months

Monday 16th January 2012
quotequote all
Can you get the specific Legacy model detail? I had a 2-litre natasp gen-2 BG (estate with "stepped" roof) which zinged upon start-up. It was the heatshield.

If it is still making that noise then it hasn't been fixed, or the fix has broken. IIRC it's not easy to get at so some dealers "fix" might involve just wedging it with something. Really it needs welding. Mild steel so easy to weld, once you've got access to it.

Watchman

5,775 posts

195 months

Monday 16th January 2012
quotequote all
Actually, I'm not sure it is mild steel. I definitely had mine repaired though... It was nearly a decade ago though. Had a few cars since and a million miles past. wobble

spunky-mon

Original Poster:

897 posts

159 months

Monday 16th January 2012
quotequote all
Cheers folks, I will get some more info from him the morn, not really sure on the type of legacy it is, what engine or anything.
He said the garage did weld up the heat shield but from the sounds of it, it was just a spot weld so this could have broken off straight away.

Watchman

5,775 posts

195 months

Monday 16th January 2012
quotequote all
spunky-mon said:
Cheers folks, I will get some more info from him the morn, not really sure on the type of legacy it is, what engine or anything.
He said the garage did weld up the heat shield but from the sounds of it, it was just a spot weld so this could have broken off straight away.
In that case I'm fairly sure that's what it is. I can't recall why they go but it could be simply that they don't stand up to the constant heat-cycling along with the vibration.

S47

1,256 posts

130 months

Wednesday 18th January 2012
quotequote all
Probably the Exhaust, that's what it is on my car, like you mentioned when the cars warm there's no rattle!!