CentOS 7 / PHP 5.6 - 7.2 upgrade issue
Discussion
Evening all,
I'll start by admitting I don't really know what I'm doing on Linux.
Now we've got that out the way, I'm trying to upgrade a CentOS 7 server from PHP 5.6 to 7.2 by following ::this guide::
However, when I get to the "yum update" step, I get the error below:
--> Finished Dependency Resolution
Error: Package: php-pear-MDB2-Driver-mysql-1.5.0-0.8.b4.el7.noarch (@epel)
Requires: php-mysql
Removing: php-mysqlnd-5.6.29-1.el7.remi.x86_64 (@remi-php56)
php-mysql = 5.6.29-1.el7.remi
Updated By: php-mysqlnd-7.2.31-1.el7.remi.x86_64 (remi-php72)
Not found
Available: php-mysql-5.4.16-48.el7.x86_64 (base)
php-mysql = 5.4.16-48.el7
Available: php-mysqlnd-5.4.16-48.el7.x86_64 (base)
php-mysql = 5.4.16-48.el7
Available: php-pecl-mysql-1.0.0-0.17.20160812git230a828.el7.remi.7.2.x86_64 (remi-php72)
php-mysql = 1:1.0.0
Available: php-mysqlnd-7.2.30-1.el7.remi.x86_64 (remi-php72)
Not found
Stumped. Any ideas please?
I'll start by admitting I don't really know what I'm doing on Linux.
Now we've got that out the way, I'm trying to upgrade a CentOS 7 server from PHP 5.6 to 7.2 by following ::this guide::
However, when I get to the "yum update" step, I get the error below:
--> Finished Dependency Resolution
Error: Package: php-pear-MDB2-Driver-mysql-1.5.0-0.8.b4.el7.noarch (@epel)
Requires: php-mysql
Removing: php-mysqlnd-5.6.29-1.el7.remi.x86_64 (@remi-php56)
php-mysql = 5.6.29-1.el7.remi
Updated By: php-mysqlnd-7.2.31-1.el7.remi.x86_64 (remi-php72)
Not found
Available: php-mysql-5.4.16-48.el7.x86_64 (base)
php-mysql = 5.4.16-48.el7
Available: php-mysqlnd-5.4.16-48.el7.x86_64 (base)
php-mysql = 5.4.16-48.el7
Available: php-pecl-mysql-1.0.0-0.17.20160812git230a828.el7.remi.7.2.x86_64 (remi-php72)
php-mysql = 1:1.0.0
Available: php-mysqlnd-7.2.30-1.el7.remi.x86_64 (remi-php72)
Not found
Stumped. Any ideas please?
I suspect most of these guides are written on a fresh install with no extensions or modules installed, it's always harder in real life!
It looks like the compatible versions of MySQL drivers etc. either aren’t available in the repositories you have selected, or there's some weird version conflicts.
If you don’t know what you’re doing on Linux (and often, even if you do), installing non-standard packages is a bit of a nightmare. I spent several months migrating a client from PHP 5.x to 7.x, compiling and testing extensions from source. Not fun. Put I was getting paid
My suggestions would be:
a) Google some more, find a better ‘guide’ - there are many
b) uninstall php and/or php-mysql and try a reinstall
c) switch to an OS version with php7 available out of the box
d) ditch the current set up and run everything in Docker containers, it’s the future
It looks like the compatible versions of MySQL drivers etc. either aren’t available in the repositories you have selected, or there's some weird version conflicts.
If you don’t know what you’re doing on Linux (and often, even if you do), installing non-standard packages is a bit of a nightmare. I spent several months migrating a client from PHP 5.x to 7.x, compiling and testing extensions from source. Not fun. Put I was getting paid

My suggestions would be:
a) Google some more, find a better ‘guide’ - there are many
b) uninstall php and/or php-mysql and try a reinstall
c) switch to an OS version with php7 available out of the box
d) ditch the current set up and run everything in Docker containers, it’s the future

Edited by deggles on Friday 29th May 18:10
If it's any help I'm running php 7.0 and 7.3 from the remi repo OK, but I didn't have 5.6 packages prexisting as I'd compiled that one myself.
Maybe get rid of the new 7.2 repos and do a yum update for everything existing, make sure that runs through OK before adding 7.2?
If you look down the bottom here at the bit about using php73 prefixed packages to leave the existing php in place, that's what I have, it works OK. so you can go systemctl start php73-php-fpm or php70-php-fpm or whatevs, they all co-exist if you use those packages. So it should resolve your dependency issue.
Maybe get rid of the new 7.2 repos and do a yum update for everything existing, make sure that runs through OK before adding 7.2?
If you look down the bottom here at the bit about using php73 prefixed packages to leave the existing php in place, that's what I have, it works OK. so you can go systemctl start php73-php-fpm or php70-php-fpm or whatevs, they all co-exist if you use those packages. So it should resolve your dependency issue.
Gassing Station | Computers, Gadgets & Stuff | Top of Page | What's New | My Stuff


