Oh Yay! Exchange failing with an Error 1002!
Oh Yay! Exchange failing with an Error 1002!
Author
Discussion

neil_cardiff

Original Poster:

17,113 posts

294 months

Tuesday 14th June 2005
quotequote all
Oh Joy of Joys,

The disk that my mdb and edb files are located on is on it's last legs.

I'm getting i/o system errors in the logs because of the cyclic redundancy error (generally a shagged disc), and exchange is bleating a 1022 error upon any access of a certain part of db. This I know because when trying to back the information store up it fails with the above error...Nooooooooooooooooo!!!

Anyhow, without trying to teach Granny how to suck eggs (I know, it should be on RAID 5, but its not me who built the server 3 years ago), can anyone suggest an easier alternative to eseutil rebuilding?

I have at present:

No users complaining of corrupt mailboxes (phew so far)

Enough space on a separate physical drive to move the dbs

A spare server if needed (brand new today funnily enough)

It's a Small Business Server 2k, in a particularly bad way :(

I'm hoping I could move the dbs across to the other physical drive, try a backup, if that fails, I'll do an eseutil, and hope that the fact that as the I/O error is on the other disc allows me to recover the db!

Your advice and Experience is welcomed.

Neil

pebbledash

795 posts

296 months

Tuesday 14th June 2005
quotequote all
make a disk level image using ghost or similar as a backup, if you can. Try restoring this image to a fresh disk.

How about exporting the mail boxes to another exchange store using exmerge.


None of these are guarenteed to work, but they have saved my bacon once or twice..



>> Edited by pebbledash on Tuesday 14th June 16:59