E-Mails not getting through.
Discussion
Can anyone assist on this :
When we send e-mails from work either with or without attachments to one of our clients they never receive them.
If I send the same mail from a gmail account they get through no problem.
Our customer has no limit for incoming e-mail size and we have no outgoing limit.
Looking through our mailserver log it gives the following (I've blanked e-mail addresses for privacy) :
192.168.10.25 [0648] 16:57:20 <<< MAIL FROM: <*****@******.co.uk>
192.168.10.25 [0648] 16:57:20 >>> 250 2.1.0 <*****@******.co.uk>... Sender ok
192.168.10.25 [0648] 16:57:20 <<< RCPT TO: <*****@*****.co.uk>
192.168.10.25 [0648] 16:57:20 >>> 250 2.1.5 <*****@*****.co.uk>... Recipient ok; will forward
192.168.10.25 [0648] 16:57:20 <<< DATA
192.168.10.25 [0648] 16:57:20 >>> 354 Enter mail, end with "." on a line by itself
192.168.10.25 [0648] 16:57:30 *** <*****@******.co.uk> <*****@*****.co.uk> 1 2383152 00:00:09 OK AXB93920
192.168.10.25 [0648] 16:57:31 >>> 250 2.6.0 2383152 bytes received in 00:00:10; Message id AXB93920 accepted for delivery
SYSTEM [04B8] 16:57:31 Client session Message id AXB93920 item 200608221657310177.tm$
192.168.10.25 [0648] 16:57:32 <<< QUIT
192.168.10.25 [0648] 16:57:32 >>> 221 2.0.0 mailgate.*******.co.uk closing connection
SYSTEM [0648] 16:57:32 Disconnected
SYSTEM [04B8] 16:57:32 Client session DNS query '*****.co.uk' 0 (3) [OK]
SYSTEM [04B8] 16:57:32 Client session Connecting to "mail.*****.co.uk"
195.152.203.2 [04B8] 16:57:37 Client session Connected
SYSTEM [04B8] 16:57:58 Client session Disconnected
SYSTEM [06FC] 17:00:06 Client session Message id AXB93920 item 200608221657310177-890668861_1.tm$
SYSTEM [06FC] 17:00:06 Client session DNS query '*****.co.uk' 0 (3) [OK]
SYSTEM [06FC] 17:00:06 Client session Connecting to "mail.*****.co.uk"
We can send mails everywhere else and our customer is receiving mails from other people.
Their IT department say that our mails aren't getting filtered by any spam system or suchlike.
Any assistance much appreciated as this is making us look somewhat unprofessional with a customer . . . .
Simon
When we send e-mails from work either with or without attachments to one of our clients they never receive them.
If I send the same mail from a gmail account they get through no problem.
Our customer has no limit for incoming e-mail size and we have no outgoing limit.
Looking through our mailserver log it gives the following (I've blanked e-mail addresses for privacy) :
192.168.10.25 [0648] 16:57:20 <<< MAIL FROM: <*****@******.co.uk>
192.168.10.25 [0648] 16:57:20 >>> 250 2.1.0 <*****@******.co.uk>... Sender ok
192.168.10.25 [0648] 16:57:20 <<< RCPT TO: <*****@*****.co.uk>
192.168.10.25 [0648] 16:57:20 >>> 250 2.1.5 <*****@*****.co.uk>... Recipient ok; will forward
192.168.10.25 [0648] 16:57:20 <<< DATA
192.168.10.25 [0648] 16:57:20 >>> 354 Enter mail, end with "." on a line by itself
192.168.10.25 [0648] 16:57:30 *** <*****@******.co.uk> <*****@*****.co.uk> 1 2383152 00:00:09 OK AXB93920
192.168.10.25 [0648] 16:57:31 >>> 250 2.6.0 2383152 bytes received in 00:00:10; Message id AXB93920 accepted for delivery
SYSTEM [04B8] 16:57:31 Client session Message id AXB93920 item 200608221657310177.tm$
192.168.10.25 [0648] 16:57:32 <<< QUIT
192.168.10.25 [0648] 16:57:32 >>> 221 2.0.0 mailgate.*******.co.uk closing connection
SYSTEM [0648] 16:57:32 Disconnected
SYSTEM [04B8] 16:57:32 Client session DNS query '*****.co.uk' 0 (3) [OK]
SYSTEM [04B8] 16:57:32 Client session Connecting to "mail.*****.co.uk"
195.152.203.2 [04B8] 16:57:37 Client session Connected
SYSTEM [04B8] 16:57:58 Client session Disconnected
SYSTEM [06FC] 17:00:06 Client session Message id AXB93920 item 200608221657310177-890668861_1.tm$
SYSTEM [06FC] 17:00:06 Client session DNS query '*****.co.uk' 0 (3) [OK]
SYSTEM [06FC] 17:00:06 Client session Connecting to "mail.*****.co.uk"
We can send mails everywhere else and our customer is receiving mails from other people.
Their IT department say that our mails aren't getting filtered by any spam system or suchlike.
Any assistance much appreciated as this is making us look somewhat unprofessional with a customer . . . .
Simon
Right hope this helps I'll try to explain with a x before my comments:
Looking through our mailserver log it gives the following (I've blanked e-mail addresses for privacy) :
192.168.10.25 [0648] 16:57:20 <<< MAIL FROM: <*****@******.co.uk>
x connection made to remote server and yu are trying to send mail
192.168.10.25 [0648] 16:57:20 >>> 250 2.1.0 <*****@******.co.uk>... Sender ok
x remote server confirms address acceptable
192.168.10.25 [0648] 16:57:20 <<< RCPT TO: <*****@*****.co.uk>
x yur server sends receipiant details
192.168.10.25 [0648] 16:57:20 >>> 250 2.1.5 <*****@*****.co.uk>... Recipient ok; will forward
x remote server confirms the recipiant is acceptable and will forward(unusual to say forward?)
192.168.10.25 [0648] 16:57:20 <<< DATA
x yur server asks how to send message data
192.168.10.25 [0648] 16:57:20 >>> 354 Enter mail, end with "." on a line by itself
x remote server confirms data can be sent and it needs a . at the end (detailed logs would show max packets etc)
192.168.10.25 [0648] 16:57:30 *** <*****@******.co.uk> <*****@*****.co.uk> 1 2383152 00:00:09 OK AXB93920
x not sure here
192.168.10.25 [0648] 16:57:31 >>> 250 2.6.0 2383152 bytes received in 00:00:10; Message id AXB93920 accepted for delivery
SYSTEM [04B8] 16:57:31 Client session Message id AXB93920 item 200608221657310177.tm$
x message accepted
192.168.10.25 [0648] 16:57:32 <<< QUIT
x yur server asking to quit connection with remote server.
192.168.10.25 [0648] 16:57:32 >>> 221 2.0.0 mailgate.*******.co.uk closing connection
x connection closing
SYSTEM [0648] 16:57:32 Disconnected
x connection disconnected
Below is begining of a new mail I think.
SYSTEM [04B8] 16:57:32 Client session DNS query '*****.co.uk' 0 (3) [OK]
SYSTEM [04B8] 16:57:32 Client session Connecting to "mail.*****.co.uk"
195.152.203.2 [04B8] 16:57:37 Client session Connected
SYSTEM [04B8] 16:57:58 Client session Disconnected
SYSTEM [06FC] 17:00:06 Client session Message id AXB93920 item 200608221657310177-890668861_1.tm$
SYSTEM [06FC] 17:00:06 Client session DNS query '*****.co.uk' 0 (3) [OK]
SYSTEM [06FC] 17:00:06 Client session Connecting to "mail.*****.co.uk"
Simon
Basically to my eyes it would appear the remote server is accepting the data and confirming it has got the message Ok.... What you don't know is where the message is going from the client mail server.
Initially I wuld say all is well at your end. I'm not sure why the remote server is saying it will Forward... mine certainly doesn't.
Hope that helps
smp said:
Looking through our mailserver log it gives the following (I've blanked e-mail addresses for privacy) :
192.168.10.25 [0648] 16:57:20 <<< MAIL FROM: <*****@******.co.uk>
x connection made to remote server and yu are trying to send mail
192.168.10.25 [0648] 16:57:20 >>> 250 2.1.0 <*****@******.co.uk>... Sender ok
x remote server confirms address acceptable
192.168.10.25 [0648] 16:57:20 <<< RCPT TO: <*****@*****.co.uk>
x yur server sends receipiant details
192.168.10.25 [0648] 16:57:20 >>> 250 2.1.5 <*****@*****.co.uk>... Recipient ok; will forward
x remote server confirms the recipiant is acceptable and will forward(unusual to say forward?)
192.168.10.25 [0648] 16:57:20 <<< DATA
x yur server asks how to send message data
192.168.10.25 [0648] 16:57:20 >>> 354 Enter mail, end with "." on a line by itself
x remote server confirms data can be sent and it needs a . at the end (detailed logs would show max packets etc)
192.168.10.25 [0648] 16:57:30 *** <*****@******.co.uk> <*****@*****.co.uk> 1 2383152 00:00:09 OK AXB93920
x not sure here
192.168.10.25 [0648] 16:57:31 >>> 250 2.6.0 2383152 bytes received in 00:00:10; Message id AXB93920 accepted for delivery
SYSTEM [04B8] 16:57:31 Client session Message id AXB93920 item 200608221657310177.tm$
x message accepted
192.168.10.25 [0648] 16:57:32 <<< QUIT
x yur server asking to quit connection with remote server.
192.168.10.25 [0648] 16:57:32 >>> 221 2.0.0 mailgate.*******.co.uk closing connection
x connection closing
SYSTEM [0648] 16:57:32 Disconnected
x connection disconnected
Below is begining of a new mail I think.
SYSTEM [04B8] 16:57:32 Client session DNS query '*****.co.uk' 0 (3) [OK]
SYSTEM [04B8] 16:57:32 Client session Connecting to "mail.*****.co.uk"
195.152.203.2 [04B8] 16:57:37 Client session Connected
SYSTEM [04B8] 16:57:58 Client session Disconnected
SYSTEM [06FC] 17:00:06 Client session Message id AXB93920 item 200608221657310177-890668861_1.tm$
SYSTEM [06FC] 17:00:06 Client session DNS query '*****.co.uk' 0 (3) [OK]
SYSTEM [06FC] 17:00:06 Client session Connecting to "mail.*****.co.uk"
Simon
Basically to my eyes it would appear the remote server is accepting the data and confirming it has got the message Ok.... What you don't know is where the message is going from the client mail server.
Initially I wuld say all is well at your end. I'm not sure why the remote server is saying it will Forward... mine certainly doesn't.
Hope that helps
you may be blocked by their ISP go to www.dnsstuff.com and check blacklists for your ip's/domains spam database lookup
a lot of isp of demainding reverse lookups in your DNS or PTR records as we had problems with AOL rejecting mail till we added PTR records also madasafish reject occasionally
are you getting any bounce back messages from
have you tried a dos mail send on port 25
In order to access your mailbox you will need 3 things:
* An active internet connection (an embarrasing stage to miss sometimes!)
* The address of a mail server capable of relaying for you - usually provided by your dialup provider (e.g. mail.domain.ext)
* A valid email address (e.g. mail@domain.ext)
The first thing to do is to open a connection from your computer to your mail server.
telnet mail.domain.ext 25
You should receive a reply like:
Trying ???.???.???.???...
Connected to mail.domain.ext.
Escape character is '^]'.
220 mail.domain.ext ESMTP Sendmail ?version-number?; ?date+time+gmtoffset?
You will then need to delcare where you are sending the email from:
HELO local.domain.name - dont worry too much about your local domain name although you really should use your exact fully qualified domain name as seen by the outside world the mail server has no choice but to take your word for it as of RFC822-RFC1123.
This should give you:
250 mail.domain.ext Hello local.domain.name [loc.al.i.p], pleased to meet you
Now give your email address:
MAIL FROM: mail@domain.ext
Should yeild:
250 2.1.0 mail@domain.ext... Sender ok
If it doesn't please see possible problems.
Now give the recipients address:
RCPT TO: mail@otherdomain.ext
Should yeild:
250 2.1.0 mail@otherdomain.ext... Recipient ok
If it doesn't please see possible problems.
To start composing the message issue the command DATA
If you want a subject for your email type Subject:-type subject here- then press enter twice (these are needed to conform to RFC 882)
You may now proceed to type the body of your message (e.g. hello mail@otherdomain.ext from mail@domain.ext)
To tell the mail server that you have completed the message enter a single "." on a line on it's own.
The mail server should reply with: 250 2.0.0 ???????? Message accepted for delivery
You can close the connection by issuing the QUIT command.
The mailserver should reply with something like:221 2.0.0 mail.domain.ext closing connection
Connection closed by foreign host.
Here are a list of problems I've encountered and their fixes
501 nouser@nosuchplace.here... Sender domain must exist
The domain that you are sending from must exist
503 Need MAIL before RCPT
A recipient has been specified before a sender.
550 mail@domain.ext... Relaying Denied
The mail server has refused to relay mail for you, this may be for any number of reasons but typical resons include:
Not using this provider for an internet connection and/or
Not using an email address provided by the owner of the server.
Some things to watch out for:
1. If you type too quickly, sometimes it won't recognise your text (weird!)
2. The backspace key sometimes does not work with some telnet clients (even though it may seem as though it does)
I'll be putting more as and when I get them and figure out how to fix each problem.
a lot of isp of demainding reverse lookups in your DNS or PTR records as we had problems with AOL rejecting mail till we added PTR records also madasafish reject occasionally
are you getting any bounce back messages from
have you tried a dos mail send on port 25
In order to access your mailbox you will need 3 things:
* An active internet connection (an embarrasing stage to miss sometimes!)
* The address of a mail server capable of relaying for you - usually provided by your dialup provider (e.g. mail.domain.ext)
* A valid email address (e.g. mail@domain.ext)
The first thing to do is to open a connection from your computer to your mail server.
telnet mail.domain.ext 25
You should receive a reply like:
Trying ???.???.???.???...
Connected to mail.domain.ext.
Escape character is '^]'.
220 mail.domain.ext ESMTP Sendmail ?version-number?; ?date+time+gmtoffset?
You will then need to delcare where you are sending the email from:
HELO local.domain.name - dont worry too much about your local domain name although you really should use your exact fully qualified domain name as seen by the outside world the mail server has no choice but to take your word for it as of RFC822-RFC1123.
This should give you:
250 mail.domain.ext Hello local.domain.name [loc.al.i.p], pleased to meet you
Now give your email address:
MAIL FROM: mail@domain.ext
Should yeild:
250 2.1.0 mail@domain.ext... Sender ok
If it doesn't please see possible problems.
Now give the recipients address:
RCPT TO: mail@otherdomain.ext
Should yeild:
250 2.1.0 mail@otherdomain.ext... Recipient ok
If it doesn't please see possible problems.
To start composing the message issue the command DATA
If you want a subject for your email type Subject:-type subject here- then press enter twice (these are needed to conform to RFC 882)
You may now proceed to type the body of your message (e.g. hello mail@otherdomain.ext from mail@domain.ext)
To tell the mail server that you have completed the message enter a single "." on a line on it's own.
The mail server should reply with: 250 2.0.0 ???????? Message accepted for delivery
You can close the connection by issuing the QUIT command.
The mailserver should reply with something like:221 2.0.0 mail.domain.ext closing connection
Connection closed by foreign host.
Here are a list of problems I've encountered and their fixes
501 nouser@nosuchplace.here... Sender domain must exist
The domain that you are sending from must exist
503 Need MAIL before RCPT
A recipient has been specified before a sender.
550 mail@domain.ext... Relaying Denied
The mail server has refused to relay mail for you, this may be for any number of reasons but typical resons include:
Not using this provider for an internet connection and/or
Not using an email address provided by the owner of the server.
Some things to watch out for:
1. If you type too quickly, sometimes it won't recognise your text (weird!)
2. The backspace key sometimes does not work with some telnet clients (even though it may seem as though it does)
I'll be putting more as and when I get them and figure out how to fix each problem.
Gassing Station | Computers, Gadgets & Stuff | Top of Page | What's New | My Stuff



