Pressure washer/snow foam issue

Pressure washer/snow foam issue

Author
Discussion

raceboy

Original Poster:

12,408 posts

247 months

Tuesday 15th June
quotequote all
Recently experienced an issue snow foaming.
I’ve got a old low end Karcher pressure washer and a generic eBay foam cannon, both have been working just fine, then the cannon appeared to stop working, not sucking up any foam and therefore not creating any ‘snow’ took it to bits couldn’t find any issues so just bought a new one, this hasn’t solved the issue, I’ve even tried the one that came in the Karcher box and that doesn’t work either.
At best I get a little snow when I start or if I go from max to min and back to max on the cannon.
When using the pressure washer on its own I can’t really see any difference to how it’s ever been.
Next step is a new pressure washer but before I do that am I missing anything stupid?

Shanksy87

297 posts

89 months

Wednesday 16th June
quotequote all
A common issue for foam canons is the mesh filter inside can easily clog and stop the unit from working, to resolve you need to clean this out and ensure you run pure water through the unit at the end of each use.

Other things to consider, are you using enough soap. I use a 1:4 soap:water ratio, and mix it vigorously before use.

Another trick is to use warm water for the water content of the soap/water mix, this helps with mixing and therefore the quality of the foam.

If this all fails, get an MTM PF22 foam canon, you won't be disappointed.

raceboy

Original Poster:

12,408 posts

247 months

Wednesday 16th June
quotequote all
Watching some YouTube videos I'd seen the mesh cleaning issue but cannon No2 is fresh out the box, and the Karcher one worked before it was replaced with Cannon No1 so saw no reason why these had now stopped, the common denominator appeared to be the pressure washer, if this is below a certain pressure can it fail to suck up the foam?
I've tried 2 different brands of foam, and all I get out the end is a fan of water. confused

Podie

46,330 posts

242 months

Wednesday 16th June
quotequote all
Have you got one of those waterstop connectors anywhere in your setup?

raceboy

Original Poster:

12,408 posts

247 months

Wednesday 16th June
quotequote all
Podie said:
Have you got one of those waterstop connectors anywhere in your setup?
Only normal hoselock connectors between the tap and hose, then hose to washer, and nothing has changed in the pipework from when it was working. frown
Water is coming out the cannon, just no snow. confused

Captain Answer

988 posts

154 months

Wednesday 16th June
quotequote all
What's your pressure like out the normal attachments when running the washer? Wonder if you've suffered a dip in output that's affecting throughput on the cannon

Podie

46,330 posts

242 months

Wednesday 16th June
quotequote all
How much snow foam are you putting in?

I wonder if it's a fitment issue of the cannon to the PW lance?

raceboy

Original Poster:

12,408 posts

247 months

Wednesday 16th June
quotequote all
Captain Answer said:
What's your pressure like out the normal attachments when running the washer? Wonder if you've suffered a dip in output that's affecting throughput on the cannon
This what what I was thinking, but don't really see a massive difference when I use the washer for pre wash or rinse, might try it on some paving slabs to see if its working at 'full strength' confused

Podie said:
How much snow foam are you putting in?

I wonder if it's a fitment issue of the cannon to the PW lance?
Not really changed any of these parameters which is thing that is confusing me. confused

Don't mind spending on a new pressure washer as the old one owes my nothing, has had a good innings and is a bit leaky, but no worse than it ever has been, but I'll be a bit frustrated if that doesn't solve it, might have to take my current cannon on a trip to a friends, to try and bottom it out.

Freakuk

1,656 posts

118 months

Wednesday 16th June
quotequote all
Is the pressure washer working normally?

raceboy

Original Poster:

12,408 posts

247 months

Wednesday 16th June
quotequote all
Freakuk said:
Is the pressure washer working normally?
That's going to be tonights job, see if it cleans a slab like it used to....could a drop in pressure out the lance affect the ability to suck up foam from the cannon?
I guess the ultimate test of that would be just hooking the cannon up to a standard pressure hose from the tap. scratchchin

raceboy

Original Poster:

12,408 posts

247 months

Thursday 17th June
quotequote all
I don't think last nights tests got me anywhere....rolleyes
Used the washer to clean the standard garden slabs and didn't notice any discernible loss of power/cleaning ability from previous cleans, so if the washer is down on power it's not really noticeable.
The washer is certainly coming to the end of it's working life, it appears to leave a similar pool of oil to what the TVR used to, but then that still worked fine.
Going to take the cannon to a friends and see it works on their washer before going shopping for a new washer, that should clear things up. scratchchin

Podie

46,330 posts

242 months

Thursday 17th June
quotequote all
raceboy said:
... before going shopping for a new washer, that should clear things up. scratchchin
Saved you some effort...

https://www.nilfiskoutlet.co.uk/products/product.a...

I run one of these with a custom length 15m hose and a shprt trigger - more than enough poke.

raceboy

Original Poster:

12,408 posts

247 months

Thursday 17th June
quotequote all
Podie said:
I'm guessing Nilfisk are a different lance conection to a Karcher. scratchchin

Podie

46,330 posts

242 months

Thursday 17th June
quotequote all
raceboy said:
Podie said:
I'm guessing Nilfisk are a different lance conection to a Karcher. scratchchin
Yep, but correct fittings are available and easy to change - circa £5 each.

Worth considering a short trigger as well, something like this - https://www.iodetail.com/collections/jet-washer-ac...

raceboy

Original Poster:

12,408 posts

247 months

Monday 21st June
quotequote all
Well it just gets more confusing....
Tried another pressure washer, and no different, so in someways that's put buying a new one off the table but why are all three cannons not working....running out of different things to try, might just strip one down and try cleaning it out and swapping to a different foam, it's getting a bit annoying now. confused