sti engine issue

sti engine issue

Author
Discussion

Jmk

Original Poster:

90 posts

126 months

Friday 13th January 2012
quotequote all
hi i have a mark 1 sti impreza it has been off the road for about 18 months i would run the car once a week on a small piece of land recently the engine has been playing up i would draw of with the turbo starting to spin at roughly 2000 rpm it would gradually build boost then at 4000 rpm it should full boost with a bit of shove (320hp/fpt and 1240 kilos) but basically at 4000 rpm the engine would build no more boost and it felt like an NA engine however it did full boost when i did a 5000 rpm launch more recently i started her up and was soon smelling a burning type smell on idle if i give the car a few revs (say 2000) after about 10 seconds i see smoke/steam coming up through the offside bonnet vent this goes away if the engine is idling i had a look in the engine bay and couldnt see anything wrong prehaps mice eating wires or ? anyone with a idea ? i can post up the engine mods if that would help cheers

ScoobieWRX

4,863 posts

176 months

Friday 13th January 2012
quotequote all
With '320'bhp it's either been chipped, has an ESL board, piggyback controller or aftermarket ECU. Which is it?

Smoke/steam could be anything like HGF (head gasket failure) leaking oil return from the turbo, loose cooling hose clip, etc etc.... Is it overheating at all? Have you checked the rad water for signs of oil film, or does the water smell a bit oily/petrol? Any signs of emulsified oil (mayonnaise) under the oil cap or in the oil filler neck?

Full spec of the car would be useful too. smile


Edited by ScoobieWRX on Friday 13th January 17:16

Jmk

Original Poster:

90 posts

126 months

Friday 13th January 2012
quotequote all
hi i will do those checks and have somebody look for a leak tommorow

the engine mods are
apexi cone induction filter
uppipe
modified fuel pump
FMIC
breathers
omega pistons
550 injectors
tubular headers
full RCM 3 inch system with prodrive backbox
HKS ssqv bov
car was mapped by duncan @ race dynamix
more than 1 person has said the car makes around about 320 hp the standard turbos limit

Nyphur

3,333 posts

138 months

Friday 13th January 2012
quotequote all
Jmk said:
more recently i started her up and was soon smelling a burning type smell on idle if i give the car a few revs (say 2000) after about 10 seconds i see smoke/steam coming up through the offside bonnet vent this goes away if the engine is idling
Check the rocker cover seal for any leaking oil. Might need a tighten or new gasket.

ScoobieWRX

4,863 posts

176 months

Friday 13th January 2012
quotequote all
Jmk said:
hi i will do those checks and have somebody look for a leak tommorow

the engine mods are
apexi cone induction filter
uppipe
modified fuel pump
FMIC
breathers
omega pistons
550 injectors
tubular headers
full RCM 3 inch system with prodrive backbox
HKS ssqv bov
car was mapped by duncan @ race dynamix
more than 1 person has said the car makes around about 320 hp the standard turbos limit
I've just had a look at your profile and read you're in Norfolk. That explains Duncan mapping it and you will have an ESL board in there.

IMHO i would have expected a bit more from 550's and a TD05 16G. The standard turbo is equivalent of the VF35 on a newage STi so 320bhp is not the limit. You're setup there for a reasonable 20-30bhp more, specially this time of the year while it's cold. Maybe Duncan mapped it during very hot weather and that was the max at the time but it's not the limit of your turbo.

I presume you fitted a 1.71bar MAP sensor from a version 3 or 4 Impreza to facilitate the remap. The standard map sensor will trip at 1.2bar and that's not enough boost for 320bhp.

Once you get it sorted you should go for a power run on your local rollers and get a printout of what it's making. They should also be able to print out a fueling and boost graph which will be useful to see how it's running.

NorthDownsScooby

170 posts

119 months

Monday 16th January 2012
quotequote all
Check the BOV - it's nearly ALWAYS the solution if it's aftermarket.

Vixpy1

42,374 posts

214 months

Monday 16th January 2012
quotequote all
ScoobieWRX said:
Jmk said:
hi i will do those checks and have somebody look for a leak tommorow

the engine mods are
apexi cone induction filter
uppipe
modified fuel pump
FMIC
breathers
omega pistons
550 injectors
tubular headers
full RCM 3 inch system with prodrive backbox
HKS ssqv bov
car was mapped by duncan @ race dynamix
more than 1 person has said the car makes around about 320 hp the standard turbos limit
I've just had a look at your profile and read you're in Norfolk. That explains Duncan mapping it and you will have an ESL board in there.

IMHO i would have expected a bit more from 550's and a TD05 16G. The standard turbo is equivalent of the VF35 on a newage STi so 320bhp is not the limit. You're setup there for a reasonable 20-30bhp more, specially this time of the year while it's cold. Maybe Duncan mapped it during very hot weather and that was the max at the time but it's not the limit of your turbo.

I presume you fitted a 1.71bar MAP sensor from a version 3 or 4 Impreza to facilitate the remap. The standard map sensor will trip at 1.2bar and that's not enough boost for 320bhp.

Once you get it sorted you should go for a power run on your local rollers and get a printout of what it's making. They should also be able to print out a fueling and boost graph which will be useful to see how it's running.
With the age of the engines and the TDO5's that are around , 320 is a faily decent number on an Sti 1.

ScoobieWRX

4,863 posts

176 months

Monday 16th January 2012
quotequote all
I've got a customer in Scotland whose V2 before he reverted it back to standard to sell it was making 340/330 and i mapped that during summertime. FMIC, CAI and 550's, original 16G.

Once i'd sorted out a boost leak, cleaned out the MAF sensor and changed the plugs the mapping was finished by the end of that day.

Suffice to say he didn't think a car that old could make the numbers it did or go quite as well, and he only sold it because his other half decided it was too much for her to handle. Shame!!


japgt

349 posts

114 months

Monday 16th January 2012
quotequote all
i also have a version 1 sti, and that is around the same power on 440 injectors, so would agree yours should be making more with the mods you have

the fact that yours appears to holding back at 4000rpm suggests the engine is in limp mode because of a potentially serious fault, i would get someone who knows what they are doing with these cars, a specialist in your area to look at it, connect it up and read for fault codes, then work from there, but you arnt doing it any favours by launching it at 5000rpm when its already holding back 4000rpm.