NEW HURACAN 610 SPYDER OWNER - A few niggles, please help :)

NEW HURACAN 610 SPYDER OWNER - A few niggles, please help :)

Author
Discussion

adam-pmwiv

Original Poster:

5 posts

4 months

Monday 26th April
quotequote all
Morning all

I have had my wonderful Huracan spider for the past week and I must say it’s AMAZING! It’s Verde Mantis and I love the colour, sadly I cannot say the same for my wife!!
I have a couple of issues that I would love your views on please:

1. A whooshing noise when using the brakes, I know ceramic brakes do squeak and I have experienced some squeals but this sound is weird. Does this sound like they need bedding in or are the pads shot?

2. VERY annoying squeak/chirp at low speeds and when reversing from the rear passenger wheel, it’s driving me mad and it sound likes I have a bird in my wheel!! ??

3. Low Washer fluid notification, my washer fluid is full or rightnear the top but this has come up a couple of times now and then disappeared.

4. The suspension lift, it goes up perfectly but when you click to lower it starts to go down and then it says lift failure with a red picture. (rather than the flashing amber lift picture) it does eventually lower but is this a sign of a dodgey pump?

Thanks so much

Adam

cgt2

1,815 posts

156 months

Monday 26th April
quotequote all
Does it drop by itself from the raised lift position above 50mph and do you get the same? I've never manually dropped it, just go above the speed threshold and it drops automatically.

adam-pmwiv

Original Poster:

5 posts

4 months

Monday 26th April
quotequote all
It tries to drop but then I get the red Error, it does eventually (after 2 mins driving) goes down and error disappears.

Thanks

Ferruccio

1,566 posts

87 months

Monday 26th April
quotequote all
If you bought off a dealer, get them to sort these issues?

adam-pmwiv

Original Poster:

5 posts

4 months

Monday 26th April
quotequote all
I didn’t buy from a dealer. I’m asking if anyone has had similar experiences

It’s going into lambo this week

Skittles001

633 posts

231 months

Monday 26th April
quotequote all
On my second H (coupes) and haven’t experienced any of those issues. Please keep us posted. Fingers crossed for you - is it under warranty?

adam-pmwiv

Original Poster:

5 posts

4 months

Wednesday 28th April
quotequote all
Sorted , lift issue was a dodgey control module and the rear brakes needed cleaning and bedding in!

Thanks

Snoopy8

5 posts

19 months

Wednesday 28th April
quotequote all
Glad to hear all sorted. Thinking about a similar purchase. Was the bill 4 x figures?? Straightforward fix?? What about the squeaks, any dead birds?

adam-pmwiv

Original Poster:

5 posts

4 months

Thursday 29th April
quotequote all
Thanks bud
The lift control module has to be replaced, the lift system worked perfectly but the brain couldn’t store the data correctly, brakes needed bedding in and dodgey water fluid sensor.

matlotus

72 posts

64 months

Thursday 29th April
quotequote all
You don’t like the colour of your wife lol???