Three Pin MBE ECU Cable How To

Three Pin MBE ECU Cable How To

Author
Discussion

philip600

213 posts

141 months

Monday 4th April 2016
quotequote all
Hi Aide, as you've probably guessed I not that computer savvy but I like to try & understand how things work. There was an earlier post in this thread showing a USB to serial port cable that was suggested would be a neater solution than going via a serial port to serial port socket but it looks like this is not possible although no one has confirmed this ( unless I've missed it ) I'm sure there must be a way of going from the 3 pin plug I have to enable my android phone to be connected to the ecu but it needs someone cleverer than me to sort it. I know it shows on the app page all the cables you need but it doesn't say why. It just seems messy going from 3 pin plug via a male & female serial port socket then a usb & finally a female usb to a OTG micro usb cable ? That's 6 different connections to connect up 2 things ?
However I've now ordered or made up all the cables I should need & am looking forward to trying the App.
Thanks for your time & help.
Kind regards, Phil.

MPETT

953 posts

173 months

Sunday 10th April 2016
quotequote all
Hi Guys,

Slight variation on the theme here..... My extension cable (D connector with 3 pins) does not work. I took it to TVR POWER to get them to try and connect to the ECU, but they couldn't either. They had to remove the cover to the ECU and connect a serial cable to USB direct to the motherboard.

I've been having some trouble with the throttles, having had them machined and bearings fitted to the spindle holes and I've had to go direct to the ECU every time, which is a PAIN IN THE ARSE/NECK/SIDE. I'd like to avoid this any more as its quite hard to get to the bottom of the foot well.

Does anyone have any peals of wisdom about how I should test the wires and check they are connected to the right pins? Dom, suggested to make a special serial extension cable and to make a hole to enable it to pass it out of the ECU cover. I could do this, but I'd like to try using the wires that are already in place.

Cheers for the advice.

Martin

p.s. I have a Tuscan Jan 00, but the ECU has Tuscan 2 written in pen on it.

philip600

213 posts

141 months

Sunday 10th April 2016
quotequote all
aide said:
philip600 said:
Hi, sorry if I sound a numpty but I just want to double check a few things. I've bought the cable that thefrog has in his earlier post & the 3 pin plug & pins. I've connected it up as follows -

Orange - TX - Pin 1
Yellow - RX - Pin 2
Black - GND - Pin 3

Can someone confirm this is correct ?
And also that I can then plug this into a laptop directly without the need for a serial to USB adaptor shown earlier ?

I've also downloaded the RS-AJP app onto my HTC One M8 android phone & have bought a USB 3.0 female to female convertor so I can join my phone lead to the USB lead I've made up, should this work OK ?
Many thanks, Phil.
Hi Phil

Can I suggest that it's far easier to get yourself up and running if you use the cables listed on the Play store.

Once you're connected and running the app it's much more fun working out the best way to connect/power/mount etc..

HTH
Aide
Ok, made my cable using the guide & connections as above. Then bought serial port to USB cable & USB to micro USB (OTG) cable as shown on play store site, plugged into 3 pin connector in passenger footwell & HTC One M8 android phone. Disable immobiliser & turn on ignition, RS-AJP app launches but no data showing, start engine, still no data. What am I doing wrong ? Kind Regards, Phil.

aide

Original Poster:

2,183 posts

131 months

Sunday 10th April 2016
quotequote all
This should help..

From another (really really long) thread:

[thanks FYP!]

FarmyardPants said:
Pic of my rs232 cable:

FarmyardPants said:

aide

Original Poster:

2,183 posts

131 months

Sunday 10th April 2016
quotequote all
philip600 said:
Ok, made my cable using the guide & connections as above. Then bought serial port to USB cable & USB to micro USB (OTG) cable as shown on play store site, plugged into 3 pin connector in passenger footwell & HTC One M8 android phone. Disable immobiliser & turn on ignition, RS-AJP app launches but no data showing, start engine, still no data. What am I doing wrong ? Kind Regards, Phil.
My guess would be the cable you made.
(You do know that if you take the lid off your ecu there is a 9pin connector that you can use to connect with directly?)

aide

Original Poster:

2,183 posts

131 months

Sunday 10th April 2016
quotequote all
aide said:
philip600 said:
Ok, made my cable using the guide & connections as above. Then bought serial port to USB cable & USB to micro USB (OTG) cable as shown on play store site, plugged into 3 pin connector in passenger footwell & HTC One M8 android phone. Disable immobiliser & turn on ignition, RS-AJP app launches but no data showing, start engine, still no data. What am I doing wrong ? Kind Regards, Phil.
My guess would be the cable you made.
(You do know that if you take the lid off your ecu there is a 9pin connector that you can use to connect with directly?)
Not sure if you're aware, but all the cables you need are freely availiable and listed!
HTH
Aide.

philip600

213 posts

141 months

Monday 11th April 2016
quotequote all
aide said:
philip600 said:
Ok, made my cable using the guide & connections as above. Then bought serial port to USB cable & USB to micro USB (OTG) cable as shown on play store site, plugged into 3 pin connector in passenger footwell & HTC One M8 android phone. Disable immobiliser & turn on ignition, RS-AJP app launches but no data showing, start engine, still no data. What am I doing wrong ? Kind Regards, Phil.
My guess would be the cable you made.
(You do know that if you take the lid off your ecu there is a 9pin connector that you can use to connect with directly?)
Hi, I did know I could do that but would prefer not to take ecu out if I can help it. With regards the cable, I've made it using your guide, soldered the connections & have checked them for continuity with a multi-meter so I'm confident the cable is fine & I've checked & double checked the cables are connected as shown ? All the other cables are as recommended on your page. Is there any settings on my phone I need to check ?

aide

Original Poster:

2,183 posts

131 months

Monday 11th April 2016
quotequote all
philip600 said:
aide said:
philip600 said:
Ok, made my cable using the guide & connections as above. Then bought serial port to USB cable & USB to micro USB (OTG) cable as shown on play store site, plugged into 3 pin connector in passenger footwell & HTC One M8 android phone. Disable immobiliser & turn on ignition, RS-AJP app launches but no data showing, start engine, still no data. What am I doing wrong ? Kind Regards, Phil.
My guess would be the cable you made.
(You do know that if you take the lid off your ecu there is a 9pin connector that you can use to connect with directly?)
Hi, I did know I could do that but would prefer not to take ecu out if I can help it. With regards the cable, I've made it using your guide, soldered the connections & have checked them for continuity with a multi-meter so I'm confident the cable is fine & I've checked & double checked the cables are connected as shown ? All the other cables are as recommended on your page. Is there any settings on my phone I need to check ?
Hi Phil

I really, and as politely and sincerely as possible, haven't time to check everyone's attempt to make a cable. And making your own cable, although cheaper, is probably an order of magnitude riskier than either:
A) simply opening the ecu cover and plugging-in an off the shelf serial cable or
B) buying the 3pin cable to externally connect instead of making your own.

As far as I'm aware there are no settings that need to be altered in order for the app to work.

All the best
Aide



Richiebhoy

61 posts

94 months

Thursday 28th April 2016
quotequote all
Confused? Bought nexus 7. Can't get the display as in previous threads and on play store. Also everything back to front

Richiebhoy

61 posts

94 months

Thursday 28th April 2016
quotequote all

Now have this. How do I format the screen ? Thanks

aide

Original Poster:

2,183 posts

131 months

Thursday 28th April 2016
quotequote all
From the PlayStore:

"(v1.07) Well, it was said that the Cerbera, from 0-100mph, will out drag a Tornado Jet.
A Tornado Jet has a Head Up Display, so I thought it fitting that a Cerbera should have one too smile
RS-AJP (v1.07), with HUD...Enjoy!"

You have inadvertently enabled HUD mode - it's a menu option.

So:
Menu->Options->DisableHUD

Then (to get the layout back):
Menu->Options->Reset GPS Layout

HTH!
Aide

Richiebhoy

61 posts

94 months

Thursday 28th April 2016
quotequote all
Done that, thanks how do I get the same layout as displayed. This is my first android.

Richiebhoy

61 posts

94 months

Thursday 28th April 2016
quotequote all

This is what I have now

aide

Original Poster:

2,183 posts

131 months

Thursday 28th April 2016
quotequote all
Richiebhoy said:
Done that, thanks how do I get the same layout as displayed. This is my first android.
Hi Richiebhoy

On the Nexus 7 the layout should automatically scale:
https://www.youtube.com/watch?v=kqf9zT8w9N8

I'm not sure how to enable/disable this as I don't have a nexus 7.

Perhaps someone else who has a nexus can help?

HTH
Aide

potash4

118 posts

70 months

Tuesday 3rd May 2016
quotequote all
Hi,

Thinking about getting the app.. Does it work portrait on the Nexus 7? I ask as the cradle I have will only hold it that way on.

Thanks

Scott

aide

Original Poster:

2,183 posts

131 months

Wednesday 4th May 2016
quotequote all
potash4 said:
Hi,

Thinking about getting the app.. Does it work portrait on the Nexus 7? I ask as the cradle I have will only hold it that way on.

Thanks

Scott
Hi Scott - landscape only I'm afraid - as the default shape of the fault code widgets lack cyclic symmetry.
i.e. they can't pivot on their midpoint.
Aide

potash4

118 posts

70 months

Wednesday 4th May 2016
quotequote all
I will see if I can fit it another way. Thx

Richiebhoy

61 posts

94 months

Sunday 26th June 2016
quotequote all
Hi, my nexus 7 updated and I lost my pre installed formatting of RS AJP. I tried to reinstall from the wiki site but they won't install, not applicable on this device. I downloaded them before no problem. Any ideas?

aide

Original Poster:

2,183 posts

131 months

Wednesday 29th June 2016
quotequote all
Richiebhoy said:
Hi, my nexus 7 updated and I lost my pre installed formatting of RS AJP. I tried to reinstall from the wiki site but they won't install, not applicable on this device. I downloaded them before no problem. Any ideas?
Hi Richiebhoy,

You can reset the STD or GPS layouts from the menu:
Menu -> Options -> Reset STD Layout
Menu -> Options -> Reset GPS Layout



HTH!
Aide

Richiebhoy

61 posts

94 months

Wednesday 29th June 2016
quotequote all
aide said:
Hi Richiebhoy,

You can reset the STD or GPS layouts from the menu:
Menu -> Options -> Reset STD Layout
Menu -> Options -> Reset GPS Layout



HTH!
Aide
Hi Aide, thanks for reply, the generation 2 doesn't automatically format the display. I downloaded the layout from your wiki site a couple of months ago and was perfect, for some reason they won't download now. Don't know what iv done, unless I accidentally reset the screen, but doesn't explain why I can't down load the shared layouts now