E70 Weird light warning problem

E70 Weird light warning problem

Author
Discussion

chadwick828

Original Poster:

11 posts

77 months

Saturday 20th May 2017
quotequote all
Hi All
I have a 2008 E70 3.0d SE and im currently getting various warnings about bulbs being out but they're not actually out and work fine.
Currently the ones that wont go away are "Two stage brake light left faulty" and "Two stage brake light right faulty"

also intermittently i will get "front right fog light faulty" and "Dipped beam left failure" (It has Xenons)
The dipped beam will turn on, then flash twice and stay on for as long as im using the car. As said earlier all the lights work perfectly and i've checked the rear lights for water ingress and they are dry.
I am at a loss, can anyone tell me where to start?
Thanks in advance!

helix402

6,045 posts

146 months

Saturday 20th May 2017
quotequote all
Get the battery tested.

chadwick828

Original Poster:

11 posts

77 months

Monday 22nd May 2017
quotequote all
The battery was replaced around 2 weeks ago...

E-bmw

6,023 posts

116 months

Monday 22nd May 2017
quotequote all
Are the lights fully standard or have some been replaced with non-canbus compliant LED/Xenon/HID aftermarket items.

chadwick828

Original Poster:

11 posts

77 months

Monday 22nd May 2017
quotequote all
All the lights are standard. It has the HUD too but that has never worked whilst i have had the car.

Current warnings on the dash are
"two stage brake light left faulty"
"two stage brake light right faulty"
"front right foglight failure"

when i turn on the dipped beams, the front left light will flash twice then stay on and "dipped beam left failure" will appear on the idrive.
Ive swapped the bulbs round and the fault did not follow the bulb. Ive replaced all the bulbs with new and this hasn't resolved anything.
There is no water ingress in the rear lights either.

Nidges2

60 posts

196 months

Wednesday 3rd March
quotequote all
Did you ever get this resolved? My wifes 2009 has started doing the exact same thing - no aftermarket bulbs fitted at all.

BMWNick01

9 posts

64 months

Thursday 4th March
quotequote all
Hello,

I have an E61 530d so its possible this might relate to your problem.
Have you checked all the wiring with a multimeter? I found several broken wires in mine which stopped my rear window opening and the third brake light stopped working. I found the broken wires coming from the tailgate, soldered them back together and everything now works fine. This fix also removed the light module code I had on the car.

Took about 1h to fix and a small amount of solder,shrinkwrap.

Nidges2

60 posts

196 months

Thursday 4th March
quotequote all
BMWNick01 said:
Hello,

I have an E61 530d so its possible this might relate to your problem.
Have you checked all the wiring with a multimeter? I found several broken wires in mine which stopped my rear window opening and the third brake light stopped working. I found the broken wires coming from the tailgate, soldered them back together and everything now works fine. This fix also removed the light module code I had on the car.

Took about 1h to fix and a small amount of solder,shrinkwrap.
Hi, I've not looked into the wiring myself - the garage had it for 2 days last week and had every light housing & bulb out over the entire car. Thanks for the pointer though.