TVR Chimaera over fuelling issues - Help needed!

TVR Chimaera over fuelling issues - Help needed!

Author
Discussion

Coxy914

Original Poster:

691 posts

209 months

Tuesday 17th June 2014
quotequote all
Right, I have a problem with severe over fuelling on my Chimaera
So far, we have replaced plugs, leads, rotor arm, vacuum advance unit repaired (vac pipe air leak) oil and filter changed new engine management coolant temp sensor redex in fuel.
It is showing Massive hydrocarbon and co readings. CO IS 5 at idle 1300 hcs + at 3500 rpm.
Has anyone else had similar problems or have an idea where we need to look next?
air flow sensor or lambdas or faulty injector maybe???

any help would be appreciated!

A900ss

3,256 posts

155 months

Tuesday 17th June 2014
quotequote all
Fuel pressure regulator?

FST 300

29 posts

130 months

Tuesday 17th June 2014
quotequote all
I would be looking at the afm as they are prone to wandering from the factory parameters

TV8

3,127 posts

178 months

Tuesday 17th June 2014
quotequote all
Any fault codes?

V8Firm

67 posts

150 months

Thursday 19th June 2014
quotequote all
I had exactly the same on my last Chimaera...really bad overfuelling, changed temp sensor; plugs leads etc, etc no joy. Local garage had a a go without success.

Finally had car trailered to Paul at PPC in Melton Mowbray to be hooked up to diagnostics...no fault codes showing!!. Paul then swopped AFM, ECU and others bits with another car.... still overfuelling.

Auto electrician called in and fault finally traced to "cross talk" in the wiring. Wiring repaired and all fixed..four figure bill though!

Apparantly it is a very rare fault and he had only heard of it once before; on a Cerbera.

Hope this is not same on yours but if it is get the auto electrician in sooner rather than later...

Good luck

Coxy914

Original Poster:

691 posts

209 months

Thursday 19th June 2014
quotequote all
I've ordered an AFM which should be here tomorrow and fingers crossed, this cure the problem!

DAN3801

15 posts

12 months

Saturday 22nd June
quotequote all
HI I know its a long time ago but how did you get on with your new maf i have the same issue with my chim 450 black smoke under load my maf looks beyond its best regards dan

mk1fan

10,591 posts

228 months

Saturday 22nd June
quotequote all
Well apparantly the ONLY thing you can do at these days is plug in RoverGuage and submit the data files to blaze_away for analysis biglaugh

If your AFM is duff, possible chance to upgrade to the larger 'Jag' version!?!

Edited by mk1fan on Saturday 22 June 15:46

Belle427

9,244 posts

236 months

Sunday 23rd June
quotequote all
I always link to this page as armed with a cheap electrical multimeter you can check nearly all the basics.
Great source of info.
http://g33.co.uk/pages/technical-fuel-injection.ht...

Edited by Belle427 on Sunday 23 June 19:13