W205 Windscreen Washers

W205 Windscreen Washers

Author
Discussion

MisterTee

Original Poster:

311 posts

77 months

Sunday 19th November 2017
quotequote all
I’ve got an (August) 2017 C350e which has suddenly developed an issue with the window washers - typical, now it’s the time of year that I need them!

The pump runs and the jets do squirt water, but only a dribble and not enough to even reach the screen. I’ve checked that the feed pipe isn’t kinked and also checked that the jets are clear, which they are.

Anyone else experienced this or have any ideas before I book it into a dealers?

Cheers

Andy

Disco_Biscuit

837 posts

162 months

Sunday 19th November 2017
quotequote all
Filter on the pump is blocked, common problem, remove washer pump, the filter is part of the rubber grommet the pump pushes into.

MisterTee

Original Poster:

311 posts

77 months

Sunday 19th November 2017
quotequote all
Thanks I’ll give that a try.

Andy

Trailhead

2,526 posts

115 months

Tuesday 8th June
quotequote all
Did that work? I’m having the same issue.

Ron240

1,113 posts

87 months

Thursday 17th June
quotequote all
Trailhead said:
Did that work? I’m having the same issue.
You do realise this thread is over 3 and a half years old?
Anyway, that will teach you both to only use official Mercedes branded screen wash. wink
Apparently Mercedes will not cover this under warranty for this reason.

Trailhead

2,526 posts

115 months

Thursday 17th June
quotequote all
Ron240 said:
Trailhead said:
Did that work? I’m having the same issue.
You do realise this thread is over 3 and a half years old?
Anyway, that will teach you both to only use official Mercedes branded screen wash. wink
Apparently Mercedes will not cover this under warranty for this reason.
The filter was blocked on the pump with congealed “non Mercedes” washer fluid.

Dealer repaired FOC and provided a bottle of Mercedes screw wash made from unicorn piss that won’t cause this problem. Also FOC. Nice guys.

Ron240

1,113 posts

87 months

Saturday 19th June
quotequote all
Trailhead said:
The filter was blocked on the pump with congealed “non Mercedes” washer fluid.
Dealer repaired FOC and provided a bottle of Mercedes screw wash made from unicorn piss that won’t cause this problem. Also FOC. Nice guys.
Well done...you definitely won a watch there. wink

I was given the remainder of this bottle of screw wash at my service yesterday (just over half full).
I looked at the ingredients but must be different to yours because unicorn piss is not mentioned. hehe It was free of charge though.