Another C Class A/C problem.

Another C Class A/C problem.

Author
Discussion

Dave3166

Original Poster:

1,605 posts

94 months

Thursday 17th June
quotequote all
Hi all.
I had my air on re-gassed last Aug/Sept.
Went to a car meet on Sunday, was blowing hot/ cold’ish!
Then when I turned it off & on again, the air con red light flashed three times & went off.
Other times it fires up as normal, but not very cold.
Has anyone any idea what this could be.
I know it could possibly be ac clutch, condenser, sensors etc etc.
Even just as simple as low refrigerant.
Whatever it is, I will get it sorted, just picking peoples brains really if anyone else has had this.
Car does not get used that much to be honest, weekend car only really.
Any thoughts greatly appreciated.
Thanks for any replies.

2013 C63 AMG if you want model.

StonedRollin

1,411 posts

178 months

Thursday 17th June
quotequote all
You've probably got a leak somewhere in the system that will need checked out before regassing otherwise give it a period of time and it will happen again.

Good luck

Dave3166

Original Poster:

1,605 posts

94 months

Thursday 17th June
quotequote all
Hi.
Thanks for reply.
Yes, could be, I’ve rad if there’s a leak and % of gas is very low then that brings on the red light.
Will put my code reader on it later, might bring up something but I’m not holding out on that.
Not sure A/C have fault codes.
Cheers.

belleair302

6,528 posts

175 months

Thursday 17th June
quotequote all
Leaking condenser probably